Messages

如果跟主題無關,但有說話要跟我說,歡迎使用本版面~

80 thoughts on “Messages

  1. 原來是師兄啊~我在討論區也看見你的發文了。
    我是03 年7S2 的畢業生,其實討論區是同年的同學開設的,所以我也放上這裏推廣一下 😛

  2. I installed your tinyMCEcomments plug-in and everything works fine, almost.  When a visitor leaves a comment, only BOLD and italic and link work, but nothing else (for instance, text-color doesn’t work)

    Why?

  3. @RR Could you see the html tags after submission? If yes, there’s something in CSS prevent that. If not, then WordPress is blocking it, check other plugins for conflict.

  4. the box, which appears if someone wants to set a Link Url ist very confusing for much people, who are afraid, when they see CODE instead of words. Is it possible to change that? I tried to find the function, that gives out this strange strings like

    {#advanced_dlg.link_title}

    and so on but did not find it. Kann you help me? Here is a picture of the box:

    http://www.claudia-klinger.de/confusing_link_set_box.gif

    In YOUR Linkbox all things are ok. (I only would like to change the input boxtitles in german)
    Excuse my bad school englisch
    greetings
    Claudia

  5. I have exactly the same problem as Claudia. I tried the suggestions in the FAQ but it didn’t help. I am upgrading from 0.4.1… Do you have any suggestions?

  6. Hey man!
    I tried to install your plugin “TinyMCEComments” on my wordpress but I could get it working :(

    After activation, a new page “MCEComments Options” appear under admin page, but even after I add some button IDs (bold, italic, underline, separator …) into “Buttons in use:” field and press “Update options”, I still don’t have any menu in my comments form. And the strangest thing is that this menu doesn’t appear even in “Preview” field of the “MCEComments Options” page!

    I use WordPress 2.5.1, I also installed Advanced TinyMCE plugin (without it there is no menu either).

    Can you help me out with this problem?
    Thanx in advance :)

  7. OMG, it worked! Thank you so much :)
    The only thing is that I need to delete and reinstall that file everytime I change the menu in order to get updated menu. Apparently, button “Update Options” doesn’t work.

  8. No, strike out previouos about not working “Update Options”. They do work, it’s just a small time delay between reload of the new menu.
    Thanx again for the useful advice and for the great plugin!

  9. Hi mk,
    installing and using mcecomments was no problem with wordpress 2.6
    BUT there is a language problem!
    The buttons tell only advanced.bold_desc or advanced.italic_desc…?

    Can you give me an advice, what’s wrong with mcecomments on my install?

    Thanks
    Matthias

  10. @Dannie : Most probably because your theme not displaying the blockquote effect. If you could see the tag in the comments in the admin interface, that means it was not filtered by the plugin nor WordPress, but is instead not shown because the theme CSS does not define the appearance of the blockquote tag in the comment space.

  11. @Richard : Hello, I can only see the “HTML Source button” on both browsers, not the “remove format” button (You can see the remove format button here right?). Maybe one of your browser has a older version of the settings in the cache?

  12. mk,

    Regarding tinyMCEcomments:
    I have WP 2.6.2 installed at http://teck.in
    The plugin is trying to load the /wp-includes/js/tinymce/themes/advanced/langs/en.js  and /wp-includes/js/tinymce/langs/en.js files which isare not present in 2.6.2 (don’t know about previous versions).

    This is a 404 in the system log.

    The same is happening with your pages also.
    http://mk.netgenes.org/wp-includes/js/tinymce/themes/advanced/langs/en.js
    http://mk.netgenes.org/wp-includes/js/tinymce/langs/en.js

    Please see if you can avoid loading these files, which do not exist in the server. This could be a reason for the slowing down of pages.

  13. Hi, great plugin. But I too cannot get the blockquote button to work. I checked the html (view page source) and it puts no html codes around the text that was selected for blockquote. All other buttons work fine.

  14. I got blockquote to work by deleting “forced_root_block” from the function brstonewline, but it quotes all the text in the box instead of only the selected text or current paragraph.

  15. I changed force_br_newlines to false so each CR would create paragraph tags, and that made it possible to only select a particular paragraph(s) for blockquote. Maybe not the best solution but a workaround I can live with.

  16. Hi, nice plugin

    I have a suggestion: make the custom css load from the current theme folder in this way :

    in function mcecomment_getcss(),

    change if ($mcecomment_options[‘css’] != ”) {
    return $mcecomment_options[‘css’];

    to

    if ($mcecomment_options[‘css’] != ”) {
    return get_bloginfo(‘template_directory’) . ‘/’ . $mcecomment_options[‘css’];

    It is very useful IMHO

  17. Hi again, will you update mcecomments for 2.7 ?

    As you can see on your blog too, when you put the mouse pointer over a button (i.e. Bold) you will not see the standard bold description but the string “advanced.bold_desc”

  18. Hey – thanks for great plugin. It installed perfectly without a problem. I can’t find any information on this, but it does not function correctly with the “reply” feature. It appears nicely and looks good, but I cannot enter any text in the box. I have the latest version of TinyMCEComments installed (as automatically upgraded by you).

    You can see this in action at my blog. Please let me know if there is any information I can give you that I will help.

  19. It seems the plugin doesn’t work with threaded comments. If you try to reply to a comment in threaded mode, you cannot get ‘focus’ on the textbox. I’m deactivating it until this gets fixed.

  20. 有一個關於tinymcecomments的問題想向您請教,希望不會讓您感到困擾,同時也盼望您的幫助。問題如下:
    我加入了“插入圖片”的功能,但是插入其他網站的圖片都無問題,只有插入本站圖片時無法顯示。通過查看html,發現本站圖片地址被自動改為相對地址,故無法顯示。請問您有無好的解決辦法。
    真誠感謝。

  21. @ibuffalo : 依我愚見,可能是 WordPress 內部留言過瀘把它換掉了。但我對 WordPress 的內部運作也不是很清楚,而且其實我也不太建議讓留言者隨便貼上圖片。很抱歉答不上你的問題啦。

  22. @mk :很感謝拔冗解答,頗受啟發。我在研究室博客http://www.xianqin.org/blog 上用了inove主題,很遺憾這個主題的評論部分和tinymcecomments不兼容,用了tinymcecomments後,inove評論部分的“回覆”、“引用”都不起作用啦。其實我很喜歡tinymcecomments這個插件,因為我們討論古文字,經常要引用些古文字圖片。有一個問題請教:wordpress評論也是用tinyMce編輯器嗎?可以通過修改代碼增強它的功能嗎?感謝!

  23. @mk : 非常感謝你的指點。我現在用的inove主題中有關回覆和引用的函數用的是insertStr,直接有insertHTML全部替代就可以了嗎?我試了一下,沒有成功。是否還要先聲明對insertHTML函式的引用呢?謝謝!

  24. Hi,
    The plugin just updated. Now, the frame for leaving a reply has disappeared in Firefox. The frame does render in MS Internet Explorer, but the following text is inserted:
    <p><br mce_bogus=”1″></p>
    If I do a page reload (refresh) in Firefox, the reply frame and the above text also appears, but only for a fraction of a second. Then it disappears.
    I  have deactivated tinymce comments for now. I hope this can be fixed because this is an excellent plugin.
    Thank you,
    S.W. Anderson

  25. problem languages!
    Здравствуйте! Очень понравился ваш плагин но у меня проблемы языко отображения,получается что как бы файл языка не обрабатываеться вообще. Посмотрите пожалуйста,может поймете о чем я пишу :http://kismedia.ru/forma-obratnoj-svyazi
    У меня идет к примеру не “Path: p”  а  “advanced.path: p”

  26. Hi Mk,
    I just installed MCEComments plugin, which should do exactly what it says, that is transform the standard wordpress comment textarea into a TinyMCE HTML editing area.
    I downloaded version 0.4.7-2 of MCEComments, unzipped the file, put it into the wordpress plugin directory (.php already), upload everything, and activate the plugin.
    The page of my wordpress web site where the comments are activated is here:
    http://www.nouvelles-alternatives.be/recettes-soupe-potimarron-taboule-millet-gateau-chocolat-sans-lait-sans-gluten
    As you can see, the comment textarea remains, without any TinyMCE buttons around it. Also, the header contains no TinyMCE.js mention.
    I expected the plugin would do the trick all by itself, but it seems I cannot get it doing it all at once. Maybe I missed something.
    Note in the code, the textarea id is ‘comment’, and the form id is ‘commentform’ as it seems it should be named.
    I do not see what can be wrong, I read the doc thoroughly, and checked the web for a hint.
    Maybe you have an idea of what I forgot to do, or of what I did wrong?
    Thank you in advance for any kind of help.
    Best regards,
    Jip

  27. Hi

    Great plugin – MCEComments. I have had it installed on my previous versions of WP. I am now just upgrading to your latest version as I am upgrading my whole system to WP 2.7.1. It all installed okay. I noticed a new field in the Options area – SKIN. Could you tell me what this is for as I could not find any written explanation about this field. Thanks.

    PS  I noticed some others are having problems with Akismet. I have never had any problems. MCEComments also has never caused a problem with any of my other plugins – which is great too.

Leave a Reply

Your email address will not be published. Required fields are marked *